RufzXP

Marco Tullio Cicerone

RufzXP "Tancredi"

Marco Tullio Cicerone

Was ist RufzXP ?

"Rufz" ist die Abkürzung für das deutsche Wort "Rufzeichen-Hören". RufzXP ist eine exzellente Trainingssoftware zur Verbesserung der Telegraphiefertigkeiten und des maximalen Hörtempos, besonders im Bereich (Ultra-) Hochgeschwindigkeits-Gehörlesen von realen Amateurfunkrufzeichen. RufzXP konzentriert sich darauf, die CW-Kenntnisse zu perfektionieren, ist also weder ein Contest-Simulator noch wird mit QRM gearbeitet. Weiterhin stehen umfangreiche Möglichkeiten zur Fortschrittsverfolgung zur Verfügung. Über die International RufzXP Toplist kann man sich mit Gleichgesinnten vergleichen.

RufzXP ist ein "muss" für jeden ambitionierten Schnelltelegraphisten und ist ein offizieller Wettkampf der IARU High Speed Telegraphy Championships.

Der Suffix "XP" zeigt, dass diese komplett neue Rufz-Version neueste Softwaretechnologie nutzt und unter MS Windows XP läuft. (Zusätzlich auch Windows 2000, NT, ME, 98).

Für diejenigen, die bereits die vorherigen Versionen von Rufz (z.Bsp. Rufz32) kennen, gibt es wenig zu erklären. Prinzipiell gelten die gleichen Regeln, und Hörfehler führen zu den gewohnten Konsequenzen. Nutzer, die sich schon damit auskennen, können gleich zum technischen Teil springen. Aber das Lesen der kompletten Dokumentation kann natürlich nie schaden.

Diese Dokumentation kann mit Hilfe der F1-Taste aufgerufen werden.

RufzXP - Einige Bemerkungen ..

Alle Rufz-Versionen wurden für das gleiche Ziel geschrieben, den Nutzer an den Rande seiner Leistungsfähigkeit, an seine Grenzen zu führen und diese zu überschreiten. Das Programm basiert auf einer altbekannten Philosophie, einfach gesagt : "Ohne Fleiß kein Preis", oder mit den Worten Ciceros "Per aspera ad asta" (über rauhe Pfade zu den Sternen). Aber das ist natürlich ein Motto für jeden wirklichen Funkamateur. Wie kann man herausragende Ergebnisse ohne Ausdauer, Zähigkeit und ständiges methodisches Studium erreichen?
RufzXP stellt das ideale Werkzeug hierfür dar, und kann bei regelmäßiger Anwendung das Hörvermögen außerordentlich verbessern. Aber Vorsicht, hier entsteht Suchtgefahr!

Der Versuch

Eigentlich ist alles ganz einfach. Gemäß den Einstellungen bei den Optionen wird zunächst das eigene Rufzeichen bzw. die Startgeschwindigkeit abgefragt, und dann beginnt der Versuch, und das erste Zufalls-Rufzeichen wird vom Computer gesendet. (Zur Vereinfachung kann ein Standardrufzeichen bzw. eine Standard-Startgeschwindigkeit bei den Optionen eingetragen werden). RufzXP wartet nunmehr auf die Eingabe des gehörten Rufzeichens. Mit dem Drücken der Enter-Taste berechnet der Computer die erreichte Punktzahl für das gehörte Rufzeichen, basierend auf der Geschwindigkeit, der Länge des Rufzeichen, der Anzahl der Hörfehler sowie der benötigten Zeit, und sendet das nächste Rufzeichen. Falls das letzte Rufzeichen richtig war, erhöht sich das Tempo, falls nicht, verringert sich das Tempo für das nächste Rufzeichen. Mit der F6-Taste kann das Rufzeichen wiederholt werden. (50% Punktabzug).
Nach dem die vorgegebene Anzahl der Rufzeichen (Standard = 50) gehört wurde, ist der Versuch beendet, und ein Fenster mit den Detaildaten des Letzten Ergebnisses erscheint. Wenn dies geschlossen wird, erscheint die komplette Ergebnisliste mit den Platzierungsdaten. (Falls in Optionen nicht ausgeschlossen)

Während des Versuchs ist zusätzlich noch die Lautstärkeregelung verfügbar. Weiterhin kann das Programm mit Shift-F4 ohne Rückfragen in die Taskleiste minimiert, oder mit Shift-F10 ganz beendet werden, um das Programm vor den Blicken Dritter zu schützen. Details dazu in der Beschreibung des Versuchsfensters.

Wie man sieht, ist RufzXP also wirklich nicht kompliziert, das weitere Studium der Details wird aber natürlich empfohlen.

RufzXP - Technische Fakten

RufzXP basiert, wie sein Vorgänger, auf einer Reihe einfacher und effektiver Algorithmen. Ohne zu sehr ins Detail zu gehen, hier die beiden Hauptpunkte:

  1. Wenn das Rufzeichen richtig gehört wurde, erhöht sich das Tempo für das nächste Rufzeichen; falls nicht, verringert es sich

  2. Die Punktberechnung basiert auf der aktuellen Geschwindigkeit (quadratischer Einfluss), der Länge des Rufzeichens (linear), der Anzahl der Fehler (quadratisch) und der benötigten Antwortzeit (logarithmisch)

Die Geschwindigkeiten (außer im Trainer-Modus) sind vordefiniert und werden aus einer Tabelle ausgewählt.Im Trainer-Modus kann die Steigerung weitgehend frei definiert werden.

Bzgl. des Dateisystems nutzt RufzXP weitgehend die Möglichkeiten des MS Frameworks. Alle Dateien von RufzXP sind im Installationsverzeichnis enthalten. (keine Registryeinträge!) Das RufzXP kann ohne Einschränkungen verändert werden. Trotzdem wird die Nutzung der Install/Uninstall-Routinen empfohlen.

Verzeichnisse / Dateien

  1. Attempts: Verzeichnis mit den Daten der einzelnen Versuche

  2. Backgrounds: Verzeichnis mit für RufzXP verfügbaren Hintergrundbilder . (Werden nur bei maximierten Fenster angezeigt)

  3. Help: Verzeichnis enthält die Hilfe-Dateien

  4. Languages: Verzeichnis enthält Übersetzungsdateien (für jede unterstützte Sprache)

  5. PrsData: Verzeichnis enthält die persönlichen Daten des Nutzers. (werden bei Einsendung von Ergebnissen für die International RufzXP Toplist verwendet)

  6. Callbase.clb: offizielle Rufzeichenbank Datei

  7. Config.rfz : Haupt Konfigurationsdatei

  8. ScoreBoard (Rufz32).scb and ScoreBoard.scb: Zwei Beispiel-Ergebnislisten-Dateien
    Es kann nur eine Ergebnisliste gleichzeitig genutzt werden, aber man kann die Ergebnislisten in anderen Verzeichnissen oder Computern benutzen.

  9. RufzXP.exe: das ausführbare RufzXP-Programm

  10. Microsoft.DirectX.DirectSound.dll, Microsoft.DirectX.DirectSound.dll: Bibliotheken der verwendeten DirectX-Technologie

RufzXP News

Neuerungen in RufzXP:

  • Trainer-Modus

  • Möglichkeit der Nutzung von eigenen Rufzeichenbänken (für lokale Contest und Training)

  • Möglichkeit eigene Ergebnislisten zu erstellen

  • integrierte Möglichkeit an die International RufzXP Toplist Ergebnisse einzusenden (direkt oder über den installierten E-Mail-Client)

  • Möglichkeit individuelle Conteste zu kreieren, und deren Einstellungen zu speichern, und auf anderen Computern zu laden

  • Hohe Konfigurierbarkeit der Modi (falls keine vordefinierten Einschränkungen entgegenstehen)

  • Hohe Konfigurierbarkeit von RufzXP selbst

Jeder Punkt wird in den entsprechenden Abschnitten noch detailliert erklärt.

RufzXP Software-Voraussetzungen

RufzXP benötigt folgende installierte Software

  • MS Windows 98, ME, 2000, XP

  • MS .NET Framework 1.1, oder höher, redistributable package

  • MS DirectX 9.0, oder höher, runtime Downloadlink


AttemtpForm - Main window

Versuchsfenster/Hauptfenster

Das ist das Hauptfenster. Hier kann ein Versuch in den veschiedenen Modis gestartet werden. (Toplist, Trainer , Contest oder HST).
Hier kann man auch auf die verschiedenen Menüpunkte zugreifen.

Das Fenster in fünf Bereiche unterteilt.

Der erste Bereich, genannt Laufender Versuch, zeigt alle Daten zum laufenden Versuch an:

  • Aktuelle Punktzahl: Laufende Summe der erhaltenen Punkte

  • Fehler im Versuch: Gesamtzahl der bisherigen fehlerhaften Rufzeichen oder Gruppen

  • Anfangsgeschwindigkeit: für den Start des Versuches gewählte Geschwindigkeit (in BpM oder WpM)

  • Max Geschwindigkeit: bisherige Maximalgeschwindigkeit im Versuch (die fehlerfrei aufgenommen wurde)

  • Min. Geschwindigkeit: bisherige Minimalgeschwindigkeit im Versuch

Der zweite Bereich, aufgeteilt in zwei Tafeln, zeigt links das gesendete und rechts das aufgenommene Rufzeichen.

Beim empfangenen Rufzeichen werden die Fehler über einen Farbcode markiert.
(Es sei denn, über Optionen wurde die Option Versuchsdaten nicht anzeigen gewählt". In diesem Fall, während des HST- oder Contest-Modus werden nur Angaben zur aktuellen Punktzahl bzw. zur benötigten Zeit gemacht. Während des Toplist- und Trainer-Modus werden die Fenster komplett unterdrückt.)

Der dritte Bereich, genannt Letztes Rufzeichen, zeigt alle Daten zum letzten gesendeten Rufzeichen (oder Gruppe) an:

  • Aktuelle Geschwindigkeit: Sendegeschwindigkeit des letzten Rufzeichens

  • Max. Punkte: die maximal erreichbare Punktzahl für das Rufzeichen, wenn es fehlerfrei und schnellstmöglich aufgenommen würde
    (quadratisch abhängig von der Geschwindigkeit, sowie linear von der Länge des Rufzeichens)

  • Erhaltene Punkte: vom Programm errechnete Punkzahl für den Empfang des letzten Rufzeichens
    Basiert auf der Anzahl der Fehler und der benötigten Antwortzeit. Ein Fehler reduziert die Punktzahl auf 1/4, zwei Fehler auf 1/9, drei Fehler auf 1/16, usw. Neu ist, wenn weniger als die Hälfte der Zeichen nicht stimmen, gibt es Null Punkte. Weiterhin erfolgt eine logarithmische Reduktion der Punktzahl für die benötigte Antwortzeit. Durch die Benutzung der F6-Taste (Rufzeichen wird einmalig wiederholt) halbiert die Punktzahl zusätzlich.

  • Fehler: Fehlerzahl beim Empfang des letzten Rufzeichens (oder Gruppe)

  • Benötigte Zeit: benötigte Zeit vom Ende des Sendens bis zum Drücken der Enter-Taste (in ms)

Der vierte Bereich ist ein Dialog zur Eingabe des eigenen Rufzeichens bzw. der Anfangsgeschwindigkeit.

Während des Versuches wird die lfd. Nr. des gesendeten Rufzeichens (Gruppe) sowie deren Gesamtzahl angezeigt. Im VIGM Modus (Blinden-Modus) erfolgt hier eine Anzeige der wichtigsten Versuchsdaten. Die rechte Hälfte des Bereiches dient zur Eingabe der gehörten Rufzeichen bzw. zum Ein-/Ausschalten des VIGM Modus .

Der fünfte und letzte Bereich dient zum Starten, Abbrechen des Versuches sowie der Beendigung des Versuches. Weiterhin kann die Lautstärke eingestellt werden.

Die folgenden Tastenkombinationen sind verfügbar:

  • ESC: Abbruch oder Pause des Versuchs

  • Pos1: Kursor springt an den Anfang des Eingabefeldes

  • Ende: Kursor spring an das Ende des Eingabefeldes

  • PfeilHoch: Die Lautstärke wird um 5 % erhöht.

  • PfeilTiefer: Die Lautstärke wird um 5 % verringert.

  • BildHoch + Shift: Lautstärke bei 50%

  • BildTiefer + Shift: Lautstärke bei 50%

  • F10 : beendet RufzXp mit Nachfrage

  • Shift + F4: Minimiert RufzXP ohne Nachfrage in ein "Notepad"-Symbol in die Taskleiste, durch Klicken auf dieses Symbol kann der Versuch fortgesetzt werden. Für die Wiederholung des Rufzeichens erfolgt 50% Punktabzug. (nicht aktiv im Contest- und HST-Modus)

  • Shift +F10: Beendet RufzXP ohne Nachfrage (nicht aktiv im Contest- und HST-Modus)


Mode settings

Versuchsfenster/Hauptfenster -
Einstellungen der Modi

RufzXP beinhaltet vier Modi:

  • Toplist

  • Trainer

  • Contest

  • HST

Für die verschiedenen Modi können Parameter unter Einstellungen gesetzt werden.
Ausnahme ist der Toplist-Modus, hier kann lediglich unter Optionen die Rufzeichenbank geändert werden. Ergebnisse auf Basis eigener Rufzeichenbänke können allerdings nicht für die International RufzXP-Toplist gewertet werden.


AttemptForm Menus

Versuchsfenster/Hauptfenster - Menüs

Wie in den nachfolgenden Tabellen beschrieben, kann hier auf alle RufzXP Funktionen über die Menüpunkte Aktionen, Modus, Sprache und Hilfe zugegriffen werden:

Aktionen:

Start

Startet einen Versuch.

Letztes Ergebnis (F3)

Wenn aktiv, werden die Daten des letzten Versuchs angezeigt.
(Platzierung, Teilnehmer-Rufzeichen, Punktzahl, Fehlerzahl, Geschwindigkeit, und detaillierte Angaben zu den gesendeten Rufzeichen oder Gruppen)

Ergebnisliste (F4)

Zeigt den Inhalt der Ergebnisliste.
Beinhaltet zeilenweise alle Daten zu den erfolgten Versuchen, geordnet nach der Punktzahl.

International Toplist (Strg+F12)

Vergleicht das beste eigene Ergebnis mit der "International RufzXP Toplist". (diese wird automatisch von der RufzXP Webseite geladen und lokal zwischengespeichert. Dabei wird die "theoretische" Platzierung angezeigt. (nur aktiv, wenn die bzgl. Option im Einstellungen-Fenster gewählt wurde)

Rekord einsenden (F6)

Ermöglicht persönliche Bestleistungen über das Internet zum Erscheinen in der Internationalen RufzXP-Topliste einzusenden.

Passwort setzen (F7)

Ermöglicht das Aktivieren oder Löschen eines Passworts um den Zugriff zu den Programmeinstellungen einzuschränken..

Optionen (F2)

Öffnet das Optionen-Fenster. Hier können alle RufzXP-Optionen geändert werden.

Sprache (F9)

Öffnet die Sprachumschaltung.
Bei der Installation wird diese automatisch aufgerufen.

Beenden (F10)

Beendet RufzXP.

Modus:

TopList

Haupt-Modus.
Während des Versuches werden 50 aus der Rufzeichenbank zufällig ausgewählte Rufzeichen gesendet. Ein Anteil von 4%..20% davon sind sogenannte Schrägstrichrufzeichen.

Trainer

Der für das kontinuierliche Hörtraining empfohlene Modus.
Über das Menü Einstellungen kann man die gewünschten Zeichen, die Länge und Art der Gruppen, den Anteil von Schrägstrichrufzeichen, Geschwindigkeitsoptionen, eigene Rufzeichenbank und Morsewichtung einstellen.

Contest

Contest-Modus.
Über das Menü Einstellungen ist es möglich, die Versuchslänge, den prozentualen Anteil der Schrägstrichrufzeichen, die max. Anzahl der Versuche pro Rufzeichen sowie eine eigene Rufzeichenbank und eine eigene Ergebnisliste einzustellen.
Weiterhin muss zunächst ein Passwort gesetzt werden. Dies wird beim Ändern der Optionen und Einstellungen sowie beim Beenden abgefragt.

HST

HST - (High Speed Telegraphy) Modus.
Dieser Modus wird bei den offiziellen IARU-HST-Championships verwendet. Die Anzahl der Rufzeichen ist auf 50 und der Anteil der Schrägstrichrufzeichen auf 10% festgelegt.
Über Einstellungen kann jedoch die Datei der Ergebnisliste spezifiziert werden. Weiterhin muss zunächst ein Passwort gesetzt werden. Dies wird beim Ändern der Optionen und Einstellungen sowie beim Beenden abgefragt.

Einstellungen (F10)

Erlaubt spezifiische Einstellungen für den jeweiligen Modus.

Sound:

(F12)

Verfügbar nur im Contest- bzw. HST-Modus.
Ermöglicht den Zugriff auf die Sound-Einstellungen. (Mittenfrequenz, Einblend- und Ausblendzeit)

Sprache:

Englisch

Ermöglicht die Umschaltung der Programmoberfläche auf Englisch

Weitere Sprachen

Ermöglicht die Umschaltung der Programmoberfläche auf weitere Sprachen (falls verfügbar)

Hilfe:

Regeln (F1)

Öffnet die Hilfedatei. (diese Datei).

Kurzanleitung (F8)

Kurzanleitung wie RufzXP prinzipiell funktioniert und wie ein Versuch abläuft

Toplist

Link zur Internationalen RufzXP-Toplist.

Homepage

Offizielle RufzXP-Homepage. Hier gibt es alle Informationen über RufzXP sowie die aktuellste Programmversion zum Download.

Kontakt zu den Autoren
(E-Mail)

Dieser Menüeintrag ist nur sichtbar, wenn ein lokales E-Mail-Programm installiert und korrekt konfiguriert wurde. (z. Bsp. Outlook, Outlook Express usw.). Damit können Fehlerberichte, Fragen und Verbesserungsvorschläge per voradressierter E-Mail an die Autoren übermittelt werden.

Kontakt zu den Autoren
(Web)

Falls eine Internet Verbindung verfügbar ist, können Fehlerberichte, Fragen und Verbesserungsvorschläge über ein Web-Formular an die Autoren übermittelt werden. Ansonsten wird die Support-E-Mail-Adresse angezeigt.

Überprüfung auf Updates

Öffnet den Update-Planer. Hier kann das Überprüfungsintervall und -Modus gesetzt werden. (Zur Ausführung wird eine Internetverbindung vorausgesetzt)

Autoren

Informationen über die Autoren und Dank an die Unterstützer.

Disclaimer

Der Disclaimer.
Hier sind Copyright und Nutzungsbestimmungen enthalten.

Danksagung

Dank an all diejenigen, die zum Gelingen des Projektes beigetragen haben.


AttemptForm - Status bar

Versuchsfenster/Hauptfenster - Statuszeile

Gemäß dem gewählten Modus werden in der Statuszeile folgende Information angezeigt::

TopList-Modus
  • Daten der Rufzeichenbank
     (Gesamtanzahl der Rufzeichen [einfache Rufzeichen - Schrägstrichrufzeichen])
  • Top-Punkte:
    maximale Punktzahl in der aktiven Ergebnisliste
  • Top-Geschwindigkeit:
    maximale Geschwindigkeit in der aktiven Ergebnisliste
  • Versuche: Gesamtzahl der erfolgten Versuche in der aktiven Ergebnisliste

Trainer-Modus
  • Gruppentyp: Gruppenaufbau im Trainer-Modus
  • Top-Punkte:
    maximale Punktzahl in der aktiven Ergebnisliste
  • Top-Geschwindigkeit:
    maximale Geschwindigkeit in der aktiven Ergebnisliste
  • Versuche: Gesamtzahl der erfolgten Versuche in der aktiven Ergebnisliste

Contest-Modus
HST-Modus

Die Statuszeile wird, um Beeinflussungen der anderen Teilnehmer zu vermeiden, in diesen Modis nicht angezeigt.


Modes

RufzXP - Modis


Free contest mode

Contest-Modus

Der freie Contest-Modus ermöglicht die Erstellung eines individuellen Contestprofils. Die hohe Konfigurierbarkeit in diesem Modus ermöglicht die Änderung nahezu aller Parameter wie Anzahl der Rufzeichen, Anteil der Schrägstrich-Rufzeichen, Anzahl der Versuche pro Teilnehmer, verschiedene Ergebnislisten und die Nutzung von eigenen Rufzeichenbanken.

Dabei bleiben die nachfolgend genannten Rufz-Grundprinzipien erhalten:

  • Variable Geschwindigkeit gemäß Rufz -Regeln

  • Punktberechnung gemäß Rufz -Regeln

Zusätzlich wird eine Möglichkeit zum Testen bzw. Probieren eines Durchgangs bereitgestellt. Durch Klick auf die TEST-Schaltfläche werden 5 Rufzeichen gesendet. Dabei kann sich der Teilnehmer mit Tastatur und Lautstärke vertraut machen. Dabei werden keine Versuchsdaten gespeichert.

Starten des Contest-Modus

Wie für den HST-Modus ist zunächst die Erstellung und Aktivierung eines Passworts erforderlich, um die Programmeinstellungen auf berechtigte Personen zu beschränken. Das Passwort ist in folgenden Fällen erforderlich:

  • Öffnen des Optionen-Fensters (eine auf die Klangeinstellungen reduziertes Fenster ist mit F12 aufrufbar)

  • Öffnen des Einstellungen-Fensters

  • Ändern des Modus: In diesem Fall wird bei korrekter Eingabe des Passworts es auch gleich gelöscht (da es dann nicht mehr benötigt wird)

  • Beenden des Programms

  • Starten des Programms

Wenn das Passwort erfolgreich aktiviert wurde, erscheint in der linken oberen Ecke des Fensters ein Schlüssel-Symbol. ( [image])

Besonderheiten

Wie das untere Bild zeigt, ist während des Contest-Modus die Ansicht der Versuchsdaten nicht standardmäßig unterdrückt. Über das Optionen-Fenster ist dies aber möglich. Wenn die Statuszeile angezeigt wird, werden aber keine Werte zum Top-Ergebnis und Top-Geschwindigkeit angezeigt. Weiterhin wird das Abbrechen/Pausieren durch ESC nicht unterstützt, da dies unabsichtlich geschehen könnte. Allerdings lässt sich ein Abbruch über die Schaltfläche Abbruch erreichen.
Nach Beendigung des Versuches werden nur die Daten des letzten Versuches angezeigt. Um den Teilnehmer nicht zu beeinflussen, wird die Anzeige der Ergebnisliste unterdrückt.

Ergebnisse aus diesem Modus sind nicht für die International RufzXP-Toplist wertbar!

Einstellungen

Wenn der Contest-Modus ausgewählt ist, können die Einstellungen über das Einstellungen-Fenster geändert werden. Dies erfolgt über den Menüpunkt Modus und Einstellungen im Versuchsfenster.

Diese Einstellungen sind verfügbar:

  • Laden Rufzeichenbank: Es kann die offizielle Rufzeichenbank oder eine eigene Rufzeichenbank ausgewählt werden.

  • Laden Ergebnisliste: Individuelle Ergebnislisten können geladen werden

  • Rufzeichen pro Versuch: minimal 10, maximal 999 (Standard: 50)

  • Versuche pro Teilnehmer: minimal 1, maximal 100 (Standard: 10)

  • Schrägstrichrufzeichen % : Anteil der Schrägstrichrufzeichen, minimal 0 % (keine), maximal 100% (alle)

  • Neue Ergebnisliste: Erstellung einer neuen und leeren Ergebnisliste

Datei Menü

Über diese Menü-Einträge können die Einstellungen für den Contest-Modus gespeichert und geladen werden.

  • Öffnen: Lädt Contest-Konfigurationsdatei aus Datei

  • Speichern: Sichert Contest-Konfigurationsdatei in Datei


HST mode

HST-Modus

Der HST-Modus (Abk. = High Speed Telegraphy) ist der Modus, in dem RufzXP beim Einsatz als offizieller Wettkampf bei den IARU HST Championships genutzt wird.

Die Regeln dafür sind recht einfach:

  • 2 Versuche pro Teilnehmer, 50 zu sendende Rufzeichen, davon genau 5 Schrägstrichrufzeichen gemäß HST-Regeln

  • Variable Geschwindigkeit gemäß Rufz -Regeln

  • Punktberechnung gemäß Rufz -Regeln

Diese Version wartet noch mit einigen Verbesserungen zum Handling auf. Nunmehr ist es möglich, mit Hilfe der Test-Schaltfläche einen Probedurchgang mit 5 Rufzeichen durchzuführen. Zuvor wird noch die Startgeschwindigkeit abgefragt. Während des Probedurchgangs kann sich der Teilnehmer mit der Tastatur und der Lautstärke vertraut machen.

Starten des HST-Modus

Wie für den Contest-Modus ist zunächst die Erstellung und Aktivierung eines Passworts erforderlich, um die Programmeinstellungen auf berechtigte Personen zu beschränken. Das Passwort ist in folgenden Fällen erforderlich:

  • Öffnen des Optionen-Fensters (eine auf die Klangeinstellungen reduziertes Fenster ist mit F12 aufrufbar)

  • Ändern des Modus: In diesem Fall wird bei korrekter Eingabe des Passworts es auch gleich gelöscht (da es dann nicht mehr benötigt wird)

  • Beenden des Programms

  • Starten des Programms

Wenn das Passwort erfolgreich aktiviert wurde, erscheint in der linken oberen Ecke des Fensters ein Schlüssel-Symbol .( [image])

Besonderheiten

Wie das untere Bild zeigt, ist während des HST-Modus die Ansicht der Versuchsdaten standardmäßig unterdrückt. Über das Optionen-Fenster kann dies in diesem Modus nicht geändert werden. Die Statuszeile wird nicht angezeigt, damit keine Werte zu Top-Ergebnis und Top-Geschwindigkeit sichtbar sind, die den Teilnehmer beeinflussen könnten.. Weiterhin wird das Abbrechen/Pausieren durch ESC nicht unterstützt, da dies unabsichtlich geschehen könnte. Allerdings lässt sich ein Abbruch über die Schaltfläche Abbruch erreichen.
Nach Beendigung des Versuches werden nur die Daten des letzten Versuchs angezeigt. Um den Teilnehmer nicht zu beeinflussen, wird die Anzeige der Ergebnisliste unterdrückt.

Einstellungen

Wegen der festen vorgegeben Regeln im HST-Modus sind hier keine Einstellungen verfügbar.


Trainer Mode

Trainer-Modus

Dies ist einer der neu in RufzXP verfügbaren Modi. Mit diesem Modus ist es möglich, sich ganz spezielle Übungen mit einer Auswahl von ganz bestimmten Zeichen zusammenzustellen. Der Modus wird über den zugehörigen Eintrag im Modus-Menü gestartet, und funktioniert ganz ähnlich wie ein normaler Versuch Es kann auch genau so Rufzeichen und Startgeschwindigkeit über das Optionen-Fenster voreingestellt werden.

Einstellungen

Über Einstellungen beim Menüpunkt Modus (F11), wird das Einstellungen-Fenster des Trainer-Modus angezeigt. Obwohl die Einstellungen sehr einfach und intuitiv sind, nachfolgend noch eine Kurzbeschreibung.

Zeichenauswahl:

Hier sind bestimmte Zeichen innerhalb der drei Gruppen von Zeichen (Buchstaben, Ziffern und Sonderzeichen) wählbar. Die Auswahl wird ggf. durch den ausgewählten Wert bei Trainer-Modus eingeschränkt. (RufzXP Modus bedeutet die Rufzeichen aus der offiziellen Rufzeichenbank, die anderen Modi sind selbsterklärend)

Weiterhin stehen unter jeder Zeichengruppe drei Schaltflächen zur Verfügung:

  • Alle: wählt alle Zeichen aus
  • keine: entfernt komplette Auswahl
  • Invertieren: Auswahl umkehren

Zusätzlich steht bei den Sonderzeichen noch eine Schaltfläche "HST Set" zur Verfügung. Damit können die Sonderzeichen auf die bei den HST-Wettbewerben üblichen Sonderzeichen eingeschränkt werden.

Hinweis: Wenigstens zwei Zeichen müssen ausgewählt werden, sonst macht es auch keinen Sinn

Trainer-Modus:

  1. RufzXP-Modus: wie im Toplist-Modus werden Zufallsrufzeichen aus der offiziellen Rufzeichenbank gesendet. Hier können aber zusätzliche Parameter wie Anzahl Rufzeichen pro Versuch , Auswahl einer Ergebnisliste , Morsezeichen-Wichtung und Geschwindigkeitsdaten eingestellt werden.
  2. Eigene Rufzeichenbank: sehr ähnlich zum RufzXP-Modus, nur kann hier eine eigene Rufzeichenbank mit eigenen Rufzeichen oder Gruppen verwendet werden.
  3. HAM Code: Amateurfunkabkürzungen für den CW-Betrieb (inkl. gängige Q-Gruppen und Zahlen)
  4. HST Mischtext: der während der HST-Championships für Mischtext verwendete Zeichensatz: 26 Bst.. (alle), 10 Ziffern (alle) and 5 Sonderzeichen (/.=,?)
  5. Buchstaben: hier werden nur die Zeichen aus der Buchstabenauswahl verwendet
  6. Ziffern: hier werden nur die Zeichen aus der Ziffernauswahl verwendet
  7. Sonderzeichen: hier werden nur die Zeichen aus der Sonderzeichenauswahl verwendet
  8. Buchstabe und Ziffern: analog
  9. Buchstaben und Sonderzeichen: analog
  10. Ziffern und Sonderzeichen: analog
  11. Alle: hier werden alle ausgewählten Zeichen verwendet

Gruppenlänge:

  • konstant: Anzahl der Zeichen pro Gruppe ist konstant (leicht)
  • variabel: Anzahl der Zeichen pro Gruppe kann zwischen einen maximalen und minimalen Wert eingestellt werden. (schwieriger)

Gruppentyp:

  • Mixed: Mischung der Zeichengruppe erfolgt innerhalb der Gruppe
    Bsp.     AE4F7 3HJU0 TG2DB 897D5
  • Getrennt: Mischung der Zeichengruppe erfolgt nur innerhalb verschiedener Gruppen
    Bsp. AEFHT 89765 FFJEP DJJNM 77463

Geschwindigkeit:

Definiert die Geschwindigkeitstabelle bzw. deren Berechnung:

  • konstant: Es wird nur in der im Optionen-Fenster gewählten Geschwindigkeit gesendet
  • steigend: Die Geschwindigkeiten erhöhen sich gemäß den RufzXp-Regeln, im Falle eines Fehlers bleibt die Geschwindigkeit aber konstant (verringert siich nicht)
  • variabel: Die Geschwindigkeiten erhöhen und vermindern sich gemäß den RufzXp-Regeln
  • Steigerungsrate: linear oder prozentual [1%..5%]. Definiert die Sprünge zwischen den verschiedenen Geschwindigkeiten in der Geschwindigkeitstabelle.

Datenbank-Verwaltung:

Hier können die Rufzeichenbank bzw. die Ergebnisliste ausgewählt werden. Die Rufzeichenbank kann nur im Modus "Eigene Rufzeichenbank" ausgewählt werden.

Anzahl Rufzeichen pro Versuch:

Hier kann die Anzahl der pro Versuch zu sendenden Rufzeichen vorgegeben werden [10..100]

Zeitbegrenzung pro Versuch

Wenn ausgewählt, wird eine Zeitbegrenzung pro Versuch aktiv. Während des Versuches wird die verbleibende Zeit angezeigt und nach Ablauf der Versuch gestoppt.

Minuten:

Zeitbegrenzung pro Versuch im Trainer-Modus (1-59 Minuten)

Schrägstrich-Rufzeichen:

Hiermit wird der prozentuale Anteil der Schrägstrich-Rufzeichen zu den normalen Rufzeichen eingestellt.
Hinweis. hier kann kein höherer Wert, als der wirkliche Anteil in der eigenen Rufzeichenbank eingestellt werden.

Morsezeichenwichtung:

Verhältnis der Längen zwischen Punkt, Strich und der Pause zwischen zwei Gruppen.

Bsp. 1:3:7 bedeutet: Punkt = 1 Punktlänge, Strich: 3 Punktlängen, Pause zwischen den Gruppen: 7 Punktlängen

Auswahl Schaltflächen

  • Neue Ergebnisliste: erzeugt eine neue und leere Ergebnisliste
  • Wiederherstellen Rufzeichenbank: die offizielle Rufzeichenbank wieder wieder eingestellt, falls zuvor eine eigene Rufzeichenbank verwendet wurde
  • OK: übernimmt die Einstellungen und schließt das Fenster


Secondary windows

RufzXP - Hilfsfenster


Results form

Letztes Ergebnis - Fenster

Dieses Fenster zeigt alle Daten des letzten Versuchs an, und wird automatisch nach Ende des Versuches angezeigt. Weiterhin ist es möglich, dieses Fenster durch Doppelklicken einer markierten Zeile in der Ergebnisliste aufzurufen.

Das Fenster ist in zwei Bereiche aufgeteilt, links die zusammengefassten Daten, rechts die Daten zu jeden gesendeten Rufzeichen.

Platzierung (nur im TopList Modus)
Fehler innerhalb eines Rufzeichens oder Gruppe Gesendetes Rufzeichen
(Eine evtl.
Wiederholung mit F6 wird mit einem roten Punkt markiert) 		Empfangenes Rufzeichen
Fehler werden mit einem Farbcode angezeigt. 		Sende-
Geschwindigk. 		Maximale Punkte
(Ideal-
punktzahl) 		Erhaltene
Punkte 		benötige Zeit
zur Aufnahme [ms] 		Ton-
Frequenz [Hz]
Teilnehmer
Punkte (des Versuches)
Anzahl Fehler (des Versuches)
Max. Geschwindigk. (des Versuches)
Min. Geschwindigk.(des Versuches)

Im Gegensatz dazu, wird während des Contest-Modus die Platzierung nicht angezeigt.

Durch Doppel-Klick auf eine Zeile (oder <Enter> in angewählter Zeile) wird das zugehörige Rufzeichen (bzw. die Gruppe) nochmals gesendet.

Datei-Menü

Über dieses Datei-Menü können die markierten Daten des Versuchs gedruckt und exportiert werden.

Die Druckoptionen entsprechen den Standards. Es ist möglich, einen Drucker bzw. dessen Druckeinstellungen auszuwählen, und eine Druckvorschau zu erhalten..

Die Daten lassen sich in diese Formate exportieren:

  • RTF (Rich Text Format): mit Seitenformatierung (Querformat empfohlen) und Verwendung der Farbcodes zur Fehleranzeige

  • TXT (Text): Textfile mit "|" als Trennzeichen

  • CSV (Comma Separated Values): Datei im CSV-Form (für Verarbeitung mit EXCEL geeignet)


Scoreboard

Ergebnislisten-Fenster

Hier werden die Platzierungen innerhalb der aktiven Ergebnisliste angezeigt. Gemäß den Einstellungen im Optionsfenster wird dieses Fenster am Ende jedes Versuches angezeigt oder auch nicht.

Im oberen Teil wird angezeigt: (immer bezogen auf die aktive Ergbebnisliste)

  • Top-Ergebnis: das beste (Punkt-) Ergebnis

  • Top-Geschwindigkeit: die höchste Geschwindigkeit

  • Gesamtanzahl der Versuche: Anzahl der Einträge in der Ergnisliste

Im mittleren Teil werden die Daten zu jedem einzelnen Versuch angezeigt.

Platzierung:
Rang in der Liste 		Rufzeichen:
während des Versuchs benutztes eigenes Rufzeichen 		Punktzahl:
Während des Versuchs erhaltene Gesamtpunktzahl 		Max. Geschw.
Maximale Geschwindigkeit während des Versuchs 		Versuch:
lfd. Nr. des Versuchs 		Datum:
Datum an dem der Versuch durchgeführt wurde

Im unteren Teil können die Daten gefiltert werden. Weiterhin können die ausgewählten Zeilen eingesendet oder gelöscht werden.

Zeilenauswahl

Gemäß den Windows-Standard ist es möglich, eine oder mehrere Zeilen auszuwählen:

  • Eine Zeile markieren: Markieren der Zeile mit dem Kursortasten bzw. Klicken mit der Maus.

  • Mehrere aufeinanderfolgende Zeilen markieren: erste Zeile markieren und, während die SHIFT-Taste gedrückt gehalten wird, die letzte Zeile markieren

  • Unterschiedliche Zeilen markieren: während die Strg-Taste gedrückt gehalten wird, mit der Maus auf die auszuwählenden Zeilen klicken

Hinweis: Mit Klick auf einen Ergebniseintrag oder Enter kann für den jeweiligen Versuch - falls verfügbar (siehe Optionen ) - eine Ansicht der detaillierten Versuchsdaten aufgerufen werden.

Ergebnis löschen

Hiermit werden die markierten Zeilen (Ergebnisse) unwiderruflich aus der aktuellen Ergebnisliste gelöscht.

Ergebnis einsenden

Als eine der Neuerungen in RufzXP kann man mit Hilfe der "Ergebnis einsenden"-Schaltfläche persönliche Bestleistungen zur Veröffentlichung in der Internationalen RufzXP-Toplist einsenden. (bei Mehrfachselektion wird nur die erste Zeile gesendet). Details werden in einem gesonderten Abschnitt behandelt.

Rufzeichenfilter

Hier kann ein Rufzeichen aus der Liste ausgewählt werden, und es werden nur die Zeilen mit diesem Rufzeichen angezeigt. Diese Funktion ist nur bei mehreren verfügbaren Rufzeichen aktiv. Mit Auswahl von "Gesamte Liste" werden alle Rufzeichen angezeigt.

Dateimenü

Mit diesem Menü ist es möglich, eine Ergebnisliste zu importieren, und Daten zu den markierten Versuchen zu exportieren bzw. zu drucken.
Wenn man alle Zeilen markiert, kann also eine komplette Ergbnisliste ausgedruckt werden.

Import einer Ergebnisliste (F2)

Hier ist es möglich, Ergebnislisten aus RufzXP oder einer früheren Version (RufzTopl.txt) zu importieren. Ergebnisse vor RufzXP werden allerdings nicht für die aktuelle Toplist gewertet. Darum werden diese Ergebnisse grau gekennzeichnet.

Export der Ergebnisdaten (F3)

Die ausgewählten Zeilen (über Mehrfachauswahl) werden in eine Ergebnislisten-Datei (*.scb,*.csv,*.txt) exportiert. Falls die Ergebnislisten-Datei schon existiert, wird diese überschrieben.

Export der gesamten Ergebnisliste (F11)

Die gesamte Ergebnisliste wird in eine Ergebnislisten-Datei (*.scb,*.csv,*.txt) exportiert. Falls die Ergebnislisten-Datei schon existiert, wird diese überschrieben.

Rufzeichenfilter (F4)

Funktionstaste für die Rufzeichenfilter-Liste

Auswahl invertieren (Strg+F5)

Hiermit können alle Zeilen markiert, bzw. alle Markierungen wieder entfernt werden.

Alles markieren - Alle Markierungen entfernen (F5)

Hiermit können alle Zeilen markiert, bzw. alle Markierungen wieder entfernt werden.

International RufzXP Toplist (F11)

Hier kann das ausgewählte eigene Ergebnis mit den Ergebnissen der "International RufzXP Toplist" verglichen werden, dabei wird die theoretische Platzierung engezeigt. Die Liste wird dabei automatisch von der RufzXP-Webseite geladen und für die spätere Verwendung zwischengespeichert. Wenn die Gültigkeitsdauer abgelaufen ist, wird - soweit eine Internetverbindung verfügbar ist - die neueste Version nachgeladen.

Ergebnis einsenden (F6)

Dieses Fenster ermöglicht, ein eigenes Ergebnis per Internet zur Veröffentlichung in der International RufzXP Toplist einzusenden.

Drucken - Seite einrichten - Seitenansicht (F7 - F8 -F9)

Entspricht den Standard-Druckfunktionen von Windows.

Schliessen (F11)

Schliesst das Ergebnislisten-Fenster.

Ergebnislisten-Modus Menü

  • Alle Ergebnisse anzeigen

  • Beste Ergebnisse für jedes Rufzeichen anzeigen: zeigt die (Anzahl wird mit nächsten Menüpunkt ausgewählt) besten Ergebnisse pro Rufzeichen an

  • Anzahl der Ergebnisse der Rufzeichen: spezifiziert die Anzahl von Zeilen pro Rufzeichen (wird nur anzeigt falls "Beste Ergebniss für jedes Rufzeichen" ausgewählt ist


Send record

Rekord einsenden - Fenster

Dies ist eine Neuerung ab RufzXP. Über dieses Dialogfenster kann ein in der Ergebnisliste markiertes Ergebnis direkt über das Internet zur Verwendung in der International RufzXP-Toplist eingesendet werden.

Die Hauptdaten des Versuches werden in den beiden Textfeldern der oberen linken Ecke angezeigt,

Weiterhin gibt es zwei Bereiche:

  1. Der obere Bereich enthält Felder, die zur Verwaltung der RufzXP-Toplist-Datenbank nötig sind.

  2. Der untere Bereich enthält Angaben zum E-Mail-Konto des Teilnehmers, bzw. Daten zum verwendeten SMTP-Server des eigenen E-Mail-Kontos beim eigenen Mail-Provider.

Rufzeichen für TopList

Falls das Rufzeichen, welches im Versuch benutzt wurde (evtl. ein Ex- oder DXpeditionsrufzeichen), nicht mit dem in der Internationalen RufzXP-Toplist registrierten Rufzeichen übereinstimmt, kann letzteres in diesem Feld angegeben werden.

Geburtstag

Die Angabe des Geburtstages ist zur korrekten Zurordnung zur Alterskategorie unbedingt notwendig. Die Angabe wird nur für diesen Zweck verwendet.

Geschlecht

OM oder YL, ist zur korrekten Zurordnung zur Geschlechtskategorie unbedingt notwendig. Die Angabe wird nur für diesen Zweck verwendet.

Vorname

Freiwillige Angabe

Nachname

Freiwillige Angabe

Kommentar

Hier kann (aber muss nicht) ein Kommentar eingetragen werden

Photo

Neu ist eine integrierte Funktion mit der man das eigene Photo zur Publizierung in der Internationalen RufzXP-Toplist einsenden kann. (nur aktiv wenn SMTP-Server Option ausgewählt ist). Das Photo, ausgewählt über "Photo auswählen", darf nicht größer als 100 KB sein, und sollte vertikal 256 Pixel besitzen.

Wenn das ausgewählte Photo abgesendet, erhält das Photo eine Markierung und die "Absenden"-Schaltfläche ist nicht länger aktiv. Um ein neues Photo zu senden, muss zunächst das alte Photo über "Photo entfernen" entfernt werden. Die Datei selbst wird dabei nicht gelöscht.

Alternativ, kann ein Photo manuell als Anhang zu einer normalen E-Mail über das lokale E-Mail-Programm gesendet werden.

E-Mail-Konto des Teilnehmers

Daten des SMTP-Servers vom Teilnehmer-E-Mail-Konto.

  • Email: Die E-Mail-Adresse des Teilnehmers im Format username@domain (die gleiche wie im E-Mail-Programm angegeben)

  • SMTP-Server: Der E-Mail-Ausgangsserver des Teilnehmer-Email-Kontos. (der im lokalen E-Mail-Programm eingestellte Wert)

  • Port: das ist der Port über den der SMTP-Server connected wird. Üblicherweise ist dies Port 25. Falls nötig (Firewalls etc.) kann aber auch ein anderer Wert spezifiziert werden.

  • Autentifizierungsprotokoll: Protokoll zur Anmeldung am SMTP-Server

    • keine Autentifizierung: ohne Autentifizierung

    • unverschlüsselt: Benutzername und Passwort werden unverschlüsselt übertragen

    • NTLM: Benutzername und Passwort werden über den NTLM-Modus übertragen

  • Benutzername: eigener Benutzername beim E-Mail-Provider
  • Passwort: eigenes Passwort beim E-Mail-Provider

  • Benutze lokales E-Mail-Programm: dabei wird eine E-Mail im lokalen E-Mail-Programm vorbereitet. Diese Mail wird beim nächsten "Senden"-Befehl im E-Mail-Programm abgesendet. Dazu muss das E-Mail-Programm gestartet werden. Falls kein lokales E-Mail-Programm installiert ist, ist diese Option nicht verfügbar.

  • Benutze angegebenen SMTP-Server: falls eine Internetverbindung aktiv ist, kann das Ergebnis direkt aus RufzXP abgesendet werden.

  • Benutze WebMailer: Bei dieser Option öffnet sich ein Fenster mit einem vordefinierten Ergebnistext. Dieser kann über die Windows Zwischenablage oder über "Drag & Drop" in das WebMailer-Formular kopiert werden.

Schaltflächen

Ergebnis einsenden

Über die Schaltfläche wird das Absenden des Ergebnisses im jeweiligen Modus eingeleitet. Dabei wird eine Plausibilitätsprüfung vorgenommen.


International TopList Form

"International TopList" - Fenster

Hier werden die internationalen Bestleistungen gemäß den IARU-Kategorien angezeigt. Perönliche Bestleistungen aus der RufzXP-Ergebnisliste werden in diese Liste zum Vergleich virtuell eingefügt. Die eigenen Daten werden aber nur lokal gespeichert und nicht automatisch zu Veröffentlichung in der RufzXP International Toplist eingesendet.

Das Fenster ist wie folgt unterteilt:

  • "International TopScore" Liste: Zeigt Rufzeichen und zugehörige Punktzahlen wie auf www.RufzXP.net an.
    (Die Maximalgeschwindigkeit bezieht sich auf den Versuch mit der Maximalpunktzahl)
    Homepage-Ergebnisse werden in Schwarz angezeigt, Homepage-Ergebnisse die von Teilnehmern in einer früheren Alterskategorie erzielt wurden, erscheinen in Grau, neue Rekorde in Fett Schwarz; und die lokalen Rekorde in Fett Rot)

  • "International TopSpeed" -Liste: Zeigt Rufzeichen und zugehörige Maximalgeschwindigkeit wie auf www.RufzXP.net an.
    (Geschwindigkeit muss dabei über 350 BpM bzw. 70 Wpm sein)
    (Die Maximalgeschwindigkeit ist unabhängig von der erreichten Punktzahl im Versuch)

  • Teilnehmer-Photos: Zeigt Photos der Teilnehmer an. Diese Photos sind auf der RufzXP-Homepage gespeichert und können von dieser heruntergeladen werden. Falls ein neues Photo verfügbar ist, wird der Nutzer darauf hingewiesen. Falls ein Photo entfernt wird, wird das lokale Verzeichnis automatisch synchronisiert.

  • Neuigkeiten: Falls vorhanden, werden wöchentlich Neuigkeiten oder Informationen von der RufzXP-Webseite angezeigt.

Sobald das Fenster geöffnet wurde, prüft RufzXP automatisch auf Aktualisierungen der RufzXP-Homepage. Falls lokal kein Abbild vorhanden sein sollte, bzw. neue Daten zur Verfügung stehen, wird, falls eine Internet Verbinung besteht, automatisch von der RufzXP-Homepage nachgeladen.
Üblicherweise wird die Homepage wöchentlich Montags gegen 22 Uhr ME(S)Z aktualisiert.

Kategorien

Hier kann eine Alters-/Geschlechts-Kategorie zur Anzeige ausgewählt werden. Lokale Ergebnisse werden hier virtuell eingefügt und rot markiert.
Mit Doppelklick auf eine rot markierte Zeile werden die zugehörigen persönlichen Daten angezeigt.

Teilnehmerdaten für Wertung

Diese Steuerelemente sind nur sichtbar, wenn ein lokal vorhandenes Rufzeichen angwählt wurde. Dann können Geburtstag und Geschlecht des Teilnehmers (OM oder YL) angegeben werden eine Einordung in die richtige Kategorie zu ermöglichen. Nach Eingabe ändert sich die angezeigte Kategorie automatisch. Die persönlichen Daten werden nur zur Einordung in die Kategorien benutzt und nicht publiziert!

Weitere Schaltflächen

  • Alle vorhandenen Photos laden: Wenn eine Internet-Verbindung besteht, werden alle verfügbaren Teilnehmerphotos von der RufzXP-Hompage geladen.

  • International TopList laden: Wenn eine Internet-Verbindung besteht, wird auf eine aktualisierte International Toplist geprüft. Falls eine aktualisierte Version vorhanden ist, wird diese von RufzXP geladen.

  • Neues Photo vorhanden, jetzt laden?: Diese Schaltfläche ist nur sichtbar, wenn auf der RufzXP-Homepage ein neues Teilnehmerphoto zur Verfügung steht. Bei Betätigung wird dieses geladen.

  • Abbrechen: Das Fenster wird geschlossen und die persönlichen Daten werden nicht gespeichert.

  • Beenden: Die persönlichen Daten werden gespeichert und das Fenster geschlossen.

Datei Menü

  • Alle vorhandenen Photos laden: Wenn eine Internet-Verbindung besteht, werden alle verfügbaren Teilnehmerphotos von der RufzXP-Hompage geladen.

  • International TopList laden: Wenn eine Internet-Verbindung besteht, wird auf eine aktualisierte International Toplist geprüft. Falls eine aktualisierte Version vorhanden ist, wird diese von RufzXP geladen.

  • Abbrechen: Das Fenster wird geschlossen und die persönlichen Daten werden nicht gespeichert.

  • Beenden: Die persönlichen Daten werden gespeichert und das Fenster geschlossen.


Option Form

Optionen-Fenster

Im Optionen-Fenster können alle RufzXP-Teile konfiguriert werden:

Das Fenster ist in vier Bereiche unterteilt:;

  • Sound-Einstellungen: Einstellung der Wellenform und Auswahl der Soundkarte

  • Standardwerte: Standardrufzeichen, Standardanfangsgeschwindigkeit und Umschaltung von BpM in WpM und umgekehrt

  • (Allgemeine) Optionen für den Versuch

  • Weitere Bedienelemente

Sound-Einstellungen

  • Tonhöhe: stellt die Mittenfrequenz [650.. 1200 Hz] des Frequenzbereiches Sendetons dar. Die Sendetonhöhe wird beim Versuch zufällig aus diesem Bereich ausgewählt. Durch Drücken auf die darunter liegende Schaltfläche wird eine Sequenz von Probetönen, bestehend aus der mittleren (MM), der maximalen (UU) und der (LL) minimalen Frequenz gesendet. Durch erneutes Klicken darauf oder eine weiter Änderung des Reglers, kann der Ton beendet werden.

  • Einblenden: Zeit [0,0..0,7 ms] für das Einblenden der Amplitude des Tones pro Punkt oder Strich. Damit wird die Anfangs-Flanke eines Punktes oder Striches weicher gestaltet. Das macht besonders bei älteren Soundkarten Sinn. Höhere Werte können Klicks vermeiden. Durch Drücken auf die darunter liegende Schaltfläche wird eine Sequenz von Probetönen, bestehend aus einigen "V" gesendet. Durch erneutes Klicken darauf oder eine weitere Änderung des Reglers, kann der Ton beendet werden.

  • Ausblenden: Zeit [0,0..0,7 ms] für das Ausblenden der Amplitude des Tones pro Punkt oder Strich. Damit wird die End-Flanke eines Punktes oder Striches weicher gestaltet. Das macht besonders bei älteren Soundkarten Sinn. Höhere Werte können Klicks vermeiden. Durch Drücken auf die darunter liegende Schaltfläche wird eine Sequenz von Probetönen, bestehend aus einigen "V" gesendet. Durch erneutes Klicken darauf oder eine weitere Änderung des Reglers, kann der Ton beendet werden.

  • Lautstärke: Ein Wert, einstellbar im Bereich [0 ..100]. (Standardwert: 50).Durch Drücken auf die darunter liegende Schaltfläche wird eine Sequenz von Probetönen, bestehend aus einigen "V" gesendet.

  • Wellenform: stellt drei verschiedene Wellenformen bereit, Sinus, Sägezahn und Rechteck.

  • Soundkarte: erlaubt die Auswahl der Soundkarte bzw. des Audio-Device für die Soundausgabe. Auch der interne Lautsprecher wird unterstützt, in diesem Fall können einige Parameter nicht eingestellt werden.

Standardwerte

  • Standard-Rufzeichen: Rufzeichen das genutzt wird, falls kein anderes angegeben wurde. Wenn die Option Rufzeichen abfragen angewählt ist, wird das eigene Rufzeichen zu Beginn des Versuches abgefragt, anderenfalls das Standardrufzeichen verwendet. Wird das eigene Rufzeichen für den Eintrag in der Ergebnisliste verwendet.

  • BpM bzw. WpM: Generelle Umschaltung der Geschwindigkeitseinheit.

  • Anfangsgeschwindigkeit: Standard-Geschwindigkeit zum Anfang des Versuches. Wenn die Option Startgeschwindigkeit abfragen angewählt ist, wird die Startgeschwindigkeit zu Beginn des Versuches abgefragt, anderenfalls wird die Standardgeschwindigkeit verwendet.
    Hinweis: Im Trainer-Modus wird ein zu den anderen Modis unterschiedlicher Wert abgespeichert.

Allgemeine Optionen

  • Versuchsdaten speichern: wenn ausgewählt, wird am Ende jedes Versuches, eine Datei mit den kompletten Versuchsdaten gespeichert. Über die Ergebnisliste kann diese wieder zurück geladen werden

  • Versuchsdaten nicht anzeigen: wenn ausgewählt, werden alle Daten auf dem Versuchsformular bzgl. des lfd. Versuches nicht angezeigt. Ausnahme: aktuelle Punktzahl und aktuelle Geschwindigkeit sowie Nr. des lfd. Rufzeichens. Die Statuszeile ist, wie im HST-Modus, nicht sichtbar

  • Eröffnungsbildschirm: wenn ausgewählt wird bei Programmstart ein Eröffnungsbildschirm angezeigt

  • Ergebnisliste anzeigen: wenn ausgewählt, wird zum Ende des Versuches die Ergebnisliste angezeigt. (außer im Contest- bzw. HST-Modus). Ansonsten wird nur das letzte Ergebnis angezeigt.

  • Schnelles Schließen: wenn ausgewählt, wird RufzXP ohne Rückfrage beendet.

  • Sound Effekte: wenn ausgewählt, sendet RufzXP zur Bestätigung eines Kommandos ein "K", sowie beim Programmende ein "73". Ansonsten werden keine akustischen Signale gesendet.

Weitere Bedienelemente

  • Standard: alle Werte werde auf die Standardwerte zurückgesetzt

  • Abbrechen: letzte Änderungen werden zurückgesetzt und das Fenster geschlossen

  • OK: Änderungen werden übernommen und gespeichert und das Fenster geschlossen

Optionsfenster-Menüs

Datei Menü

Hier gibt es sieben Menüpunkte:

  • Test: sendet "VVV TEST TEST AR" zum Test der Einstellungen und Optionen

  • Standard: stellt die Standardwerte wieder her

  • Abbrechen: letzte Änderungen werden zurückgesetzt und das Fenster geschlossen

  • OK: Änderungen werden übernommen und das Fenster geschlossen

  • Speichern WAV-File: nach Bestätigung wird auf Festplatte eine WAV-Datei geschrieben. Diese Sounddatei enthält einen 60 Sekunden langen Text bestehend aus der wiederholten Gruppe "PARIS". Hiermit kann die Genauigkeit der Geschwindigkeitserzeugung gemessen werden.

  • Speichern: Speichert alle Optionswerte auf Festplatte

  • Speichern und Beenden: Speichert alle Optionswerte auf Festplatte, und schließt das Fenster.

Einstellungen Menü

  • Hintergrund ändern: ermöglicht das Hintergrundbild zu ändern (nur sichtbar wenn das Hauptfenster maximiert ist).
  • Zuordnung Schrägstrich-Taste: ermöglicht eine Änderung der Zuordnung der Schrägstrich-Taste. ("/"). Wird für "exotische" Tastatur-Layouts benötigt.
  • Passwort: zum Erstellen, Ändern oder Löschen des Passworts . Diese Schaltfläche ist nicht aktiv während des Contest- oder HST-Modus.

Sprachen Menü

Ganz einfach, gemäß den vorhandenen Dateien im Unterverzeichnis /language gibt es hier Menüeinträge zum Ändern der Sprachoberfläche.
Das gleiche Unterverzeichnis enthält eine Datei genannt Translation module.txt, welche alle Englischen Texte, die von RufzXP benutzt werden, enthält. Das Format ist sehr einfach. Jede Zeile enthält zwei Teile die in <> eingefasst sind. Die englische Vorlage steht im linken Teil, die gewünschte Sprache kommt in den rechten Teil. Um Layoutprobleme zu vermeiden, sollten, soweit möglich, die Textlängen ähnlich sein.
Wer gerne eine neue Sprache erstellen möchte, sollte unbedingt vorher mit den Autoren in Kontakt treten.


General informations

RufzXP - Allgemeine Informationen


Errors color code

Farbcodes

Zur Fehleranzeige werden folgende Farbcodes benutzt::

Fehler | rote Farbe
Fehlendes Zeichen | blaue Farbe
Zusätzliches Zeichen | Gelbe Farbe

Beispiele:

Das gesendete Rufzeichen oder die gesendete Gruppe wurde(n) korrekt aufgenommen.

1 Fehler

2 Fehler

3 Fehler

Ein fehlendes Zeichen

Ein zusätzliches Zeichen


Personal callbase - Format

Eigene Rufzeichenbank

RufzXP erlaubt den Einsatz eigener Rufzeichenbänke im Contest - unnd Trainermodus .

Wichtig ! Ergebnisse die auf eigenen Rufzeichenbänken basieren sind für die International RufzXP-Toplist nicht wertbar!

Eine eigene Rufzeichenbank ist eine einfache Textdatei. (die Extension ist nicht wichtig, es wird aber .txt empfohlen. Sie kann einfach mit dem Windows Notepad oder einem anderen Texteditor erzeugt werden. Pro Zeile darf nur ein Rufzeichen stehen.

Beispiel:

IV3XYM
DL4MM
IV3NCC
DL4MM/P
DL2OBF
IV3AJT
A4/IV3NC
Wenn die Datei mit einem aussagekräftigen Namen versehen wurde, wie z.Bsp. contest2005.txt, trainer2004.txt kann sie dann über die Menüpunkte Modus- Einstellungen - Einstellungen - Rufzeichenbank ändern aktiviert werden.
Achtung! Von den Schrägstrichrufzeichen muss gemäß den Einstellungen eine genügende Anzahl vorhanden sein. Also bei 10 % von 50 Rufzeichen pro Durchgang müssen mindestens 5 Schrägstrichrufzeichen enthalten sein.


Password form

Passwort-Fenster

Die Art das Passwort zu setzen, zu ändern und zu löschen, entspricht den üblichen Standards.

Passwort Abfrage: Drei Versuche stehen für die korrekte Eingabe des Passworts zur Verfügung. Zur Bestätigung ist die OK-Schaltfläche zu betätigen.

Passwort setzen: Das Passwort (6..10 Zeichen) muss doppelt eingegeben werden. Falls die beiden Strings übereinstimmen, kann das Passwort mit der Schaltfläche Passwort setzen aktiviert werden.

Passwort löschen: Dafür gibt es zwei Möglichkeiten:

  • wenn beide Passwort-Felder leer sind, kann über die Passwort löschen - Schaltfläche das Passwort gelöscht werden
  • funktioniert analog zum Passwort setzen, allerdings müssen beide Passwort-Felder leer bleiben. (vorher muss das zu löschende Passwort eingegeben werden)
    Wenn dies zutrifft, kann mit der Schaltfläche     Passwort löschen das Passwort deaktiviert werden.


V.I.G.M. Mode

V.I.G.M. Modus

(Visual Impaired Graphic Mode
Mode für Blinde)

Dieser Modus wurde speziell für sehgeschädigte Benutzer geschrieben.
Während des Versuchs werden alle wichtigen Daten zusätzlich im Textfeld links von der Eingabezeile angezeigt.
Diese können problemlos mit spezieller Hardware wie Braille-Bildschirmleser gelesen werden. Folgende Werte werden angezeigt:

  1. Lfd. Rufzeichen-Nummer : Gesamtzahl der Rufzeichen

  2. Ergebnis

  3. Anzahl der falsch gehörten Rufzeichen

  4. Max. Geschwindigkeit (die Einheit wird nicht angezeigt)

  5. Aktuelle Geschwindigkeit (die Einheit wird nicht angezeigt)

Wenn die Option "Hide Attempt" gewählt ist, wird nur die lfd. Rufzeichen-Nummer und das Ergebniss angezeigt.

Der Modus kann auf zwei Arten aktiviert werden::

  1. Kommandozeilenoption -vigm (Eingabe: RufzXP - vigm). RufzXP startet im VIGM Modus.

  2. In der Rufzeichen-Eingabezeile im Versuchsfenster könnnen folgende Kommandos eingegeben werden:
    VIGMON (VIGM Modus wird eingeschalten)
    VIGMOFF (VIGM Modus wird ausgeschalten)


HAM Code

161 | Best Regards and Love & Kisses (73 + 88) |
33 | Fondest Regards |
55 | Best Success |
73 | Best Regards |
88 | Love & Kisses |
A | Short hand for the number 1 |
ABT | About |
AGN | Again |
ANS | Answer |
ANT | Antenna |
B4 | Before |
BC | Broadcast |
BCNU | Be Seeing You |
BD | Bad |
BK | Back or Break |
BN or BEN | Been |
BTU | Back To You |
BURO | QSL Bureau |
C | Correct |
CB | Callbook or Citizen Band |
CBA | Call Book Address |
CFM | Confirm |
CL | Closing Station Down |
CLG | Calling |
CLR | Clear |
CONDX | Conditions |
CONGRATS | Congratulations |
CPY | Copy |
CQ | General Call for a QSO (Contact) |
CUD | Could |
DE | From (eg... W3AA de W3DF) |
DR | Dear (Used by overseas Hams for Sir, Mister) |
DSW | See You Again (Russian) |
DWN | Down |
DX | Long Distance Contact, or a Rare Station |
EL | Element (as in 3 EL Yagi) |
ENUF | Enough |
ES | And |
FB | Fine Business (Ham jargon for very good) |
FD | Field Day |
FER | For |
FIST | Unique characterisitc of an operater's sending of CW |
FONE | Phone (as in AM or SSB) |
FM | From |
FQ, FREQ | Frequency |
GA | Good Afternoon or Go Ahead |
GB | Good Bye |
GD | Good or Good Day |
GE | Good Evening |
GG | Going |
GM | Good Morning |
GN | Good Night |
GND | Ground |
GP | Ground Plane |
GUD | Good |
HAM | Amateur Radio Operator |
HC | Home Call |
HI | Laughter on CW |
HNY | Happy New Year |
HPE | Hope |
HR | Here or Ham Radio |
HV | Have |
HVY | Heavy |
HW, HW? | How, or How Do You Copy Me? |
II | I Repeat |
INV VEE | Inverted Vee |
JA | Japan |
JMP | Jump |
K | Please Transmit |
KN | Only the station I am working should transmit |
KNW | Know |
LID | Poor Operator |
LP | Log Periodic (type of directional antenna) or Long Path |
LSB | Lower Sideband |
LW | Long Wire (type of antenna) |
MGR | QSL Manager |
MNI | Many |
MSG | Message |
MULT | Multiplier |
N | No or the number 9 |
NIL | Nothing Heard or No Copy |
NR | Near or Novice Round Up |
NW | Now or North West |
OB | Old Boy |
OC | Old Chap |
OM | Old Man (Ham jargon for an experienced operator) |
OP | Operator, or Name |
OPR | Operator or Operate |
OT | Old Timer (A long time HAM) |
PSE | Please |
PWR | Power |
PO | Power Output |
PFX | Prefix |
QRA | The name of my station is ... | What is the name of your station?
QRB | The approx. distance between our stations is ... | How far approximately are you from my station?
QRK | The readibility of your signal is: (1) Bad, (2) Poor, (3) Fair, (4) Good, (5) Excellent | What is the readibility of my signal?
QRL | The frequency is busy | Is the frequency busy?
QRM | Your transmission is being interfered with | Is my transmission being interfered with?
QRN | I am troubled by static | Are you troubled by static?
QRO | Increase power | Should I increase power?
QRP | Decrease power. Also used to designate a station using low power | Should I decrease power?
QRQ | Send faster | Should I send faster?
QRS | Send slower | Should I send slower?
QRT | Stop transmitting | Should I stop transmitting?
QRU | I have nothing for you | Have you anything for me?
QRV | I am ready | Are you ready?
QRX | Please standby for ... | Should I standby?
QRZ | You are being called by ... | Who is calling me?
QSA | The strength of your signal is: (1) Barely perceptible, (2) Weak, (3) Fair, (4) Good, (5) Excellent | What is the strength of my signal?
QSB | Your signal is fading | Is my signal fading?
QSK | I can operate break-in | Can you operate break-in?
QSL | I acknowledge receipt | Do you acknowledge receipt?
QSO | I can communicate with ... | Can you communicate with ...?
QST | General call preceding a message to all amateurs |
QSX | I am listening on ... | Will you listen on ...?
QSY | I will change my transmit frequency | Should I change my transmit frequency?
QTC | I have traffic for you | Do you have traffic for me?
QTH | My location is ... | What is your location?
QSLL | QSL 100% (Term used by overseas hams) |
R | Message Received or Correct |
RCV | Receive |
RCVD | Received |
RCVR | Receiver |
RIG | Equipment |
RPRT or RPT | Report or Repeat |
RX | Receiver |
SHUD | Should |
SIG | Signal |
SK | This is my last transmission |
SKED | Schedule |
SN | Soon |
SNW | Snow |
SP | Short Path |
SRI | Sorry |
STN | Station |
SWL | Short Wave Listner |
T | Short hand for the number Zero |
TEMP | Temperature |
TEST | Contest |
TFC | Traffic |
TIL | Until |
TKS | Thanks |
TCVR | Transceiver |
TT | That |
TU | Thank You |
TX | Transmitter |
TNX | Thanks |
U | You |
UFB | Ultra Fine Business (Ham jargon for very good - excellent) |
UR | Your |
USB | Upper Sideband |
VERT | Vertical Antenna |
VY | Very |
W | Watts |
WATSA | What'Cha Say |
WID | With |
WK | Work |
WKD | Worked (Ham jargon for making a contact with a station) |
WKG | Working |
WL | Will |
WPM | Words Per Minute (a measure of code speed) |
WRK | Work |
WUD | Would |
WX | Weather |
XCVR | Transceiver |
XMTR | Transmitter |
XTAL | Crystal |
XYL | Wife |
YF | Wife |
YL | Young Lady |
YR, YRS | Your or Year, Yours or Years |
Z | Zulu, GMT, or UTC Time |
ZZ | Sleep |


RufzXP F.A.Q.

In diesem Abschnitt finden Sie die Antworten zu den häufigsten Fragen. Falls nicht, bitte die Autoren kontaktieren.

Was ist das Ziel von RufzXP ? | Diese Version von RufzXP wurde als Werkzeug für die Verbesserung der Hör-Fertigkeiten besonders im Hochgeschwindigkeitsbereich entwickelt.
Was ist der Unterschied zwischen Rufz 3.2 und RufzXP ? | Auf Grund der bisherigen Programm-Struktur funktionierte Rufz bisher nur in einem reinen DOS-Modus oder unter einer DOS-Emulation ( DOSBox ). Diese Version arbeitet mit allen Version von Windows, beginnend von Windows 98.
Welche zusätzliche Software benötigt RufzXP ? | Wie viele andere Programme benötigt RufzXP ein installiertes .NET Framework redistributable package 1.1 oder höher. Bei Bedarf kann es hier geladen werden. Zusätzlich wird noch die letzte Version von DirectX (v9) benötigt. Falls diese nicht bereits über den Microsoft Update Dienst geladen wurde, bitte hier downloaden.
Wie kann ich die Einstellungen im Contest-Modus auf andere Computer duplizieren? | Unter Einstellungen den Menüpunkt Datei auswählen und unter Speichern die Einstellungen unter einem selbst gewählten Dateinamen abspeichern. Auf den anderen Computern geht es dann umgekehrt, unter Einstellungen, Datei und Öffnen kann diese Datei wieder zurückgeladen werden.
Wenn ich eine Anfangsgeschwindigkeit eingebe, wird diese automatisch geändert, warum? | Der eingegebene Wert war nicht in der Geschwindigkeitstabelle enthalten und wird deshalb auf den nächsten Wert gerundet.
Manchmal ist es nicht passend, dass andere mein Arbeiten mit RufzXP bemerken. Gibt es eine einfache Möglichkeit, die Anzeige des Programms zu unterdrücken? | Es besteht die Möglichkeit, mit Shift + F4 das ggf. laufende Senden zu unterbrechen und das Programmfenster zu minimieren. Es ist dann nur noch in der Taskleiste als Icon sichtbar. Mit einem Klick auf das Icon kann der Versuch weitergeführt werden. Das Rufzeichen wird dann nochmals gesendet. (falls nicht bereits mehrfach gesendet) Mit Shift+F10 kann das Programm sofort und vollständig beendet werden.
Heute habe ich eine tolles Ergebnis im Contest-Modus erreicht. Ich finde aber keine Möglichkeit, es für die Internationale Rufz-Topliste einzureichen. Kann man da etwas machen? | Leider nicht. Da im Contest-Modus viele Parameter frei einstellbar sind, wäre eine Vergleichbarkeit der Ergebnisse nicht gewährleistet. Aus diesem Grund werden nur Ergebnisse aus dem Toplist- oder HST-Modus gewertet.
Ich habe an meinem Rechner keine Internetverbindung. Kann ich meine Bestleistungen auch über einen anderen Rechner einsenden ? | Einfach das Ergebnis aus der Ergebnisliste in eine Datei exportieren. Über Datei und Exportieren Ergebnisdaten kann das markierte Ergebnis gespeichert werden. Diese Datei, oder deren Inhalt kann nun von einem beliebigen Rechner versendet werden.
Ich habe Fehler im Programm entdeckt bzw. habe Ideen zur Programmverbesserung. Wohin kann ich mich wenden? | Am besten ist eine E-Mail an die Autoren . Dan kann der Fehler schnellstmöglich behoben und eine neue Version freigegeben werden. Bitte immer möglichst viele konkrete Details zum Problem angeben. (Betriebssystem, RufzXP-Modus, benutzte Rufzeichenbank und Ergebnisliste, usw.). Ideen und Kritik sind natürlich auch willkommen und werden ggf. in zukünftige Updates mit einfließen.
Ich möchte gerne RufzXP in eine weitere Sprache übersetzen. Wie kann ich das tun? | Der beste Weg ist, sich zunächst mit den Autoren in Verbindung zu setzen. So kann sichergestellt werden, dass nicht schon jemand anderes sich die gleiche Arbeit macht. Ansonsten gibt es die Datei Translation module.txt im Verzeichnis /Languages als Ausgangsbasis. Für weitere Instruktionen bitte hier klicken.
Wofür steht der Zusatz "Tancredi" ? | Dieser Frage ist eine eigene Seite gewidmet.


Legenda

Legende / Begriffserklärungen

Hier werden die in der RufzXP-Dokumentation am häufigsten auftretenden Begriffe erläutert:

Anfangs- geschwindigkeit | Die Geschwindigkeit zum Beginn des Versuches
BpM / WpM | Maßeinheit für die Morsegeschwindigkeit. Sie stellt die Anzahl der Zeichen bzw. Wörter dar, wenn das Wort PARIS eine Minute lang gegeben wird. BpM = WpM * 5 und WpM = BpM / 5.
Contest-Modus | Ein (privater) Contest, wo Parameter weitgehend selbst konfiguriert werden können.
Rufzeichenbank | Eine Datenbank mit den einfachen und Schrägstrichrufzeichen die während eines RufzXP-Versuchs zufällig zum Senden ausgewählt werden. Die Datei enthält mehr als 50000 verschiedene Rufzeichen. Alle Rufzeichen sind reale Rufzeichen und wurden nicht künstlich erzeugt.
Eigenes Rufzeichen | Das Amateurfunk-Rufzeichen des Teilnehmers (dasjenige welches für den Versuch genutzt wird)
Einfache Rufzeichen | Rufzeichen ohne Schrägstrich
Einstellungen | Parameter innerhalb eines RufzXP-Modus
Ergebnis | Summe der Punktzahlen im Versuch
Ergebnisliste | Datenbank die alle Ergebnisdaten zu den erfolgten RufzXP-Versuchen enthält.
HST-Modus | Ein Contest mit vorgegebenen Regeln (2 Versuche pro Teilnehmer, 50 zu sendende Rufzeichen, 10% Schrägstrichrufzeichen) (gemäß den Regeln für die IARU High Speed Telegraphy Championships)
International RufzXP-Toplist | Eine im Internet wöchentlich erscheinende weltweite Topliste, zu der RufzXP-Nutzer ihre Ergebnisse einsenden können, um sich miteinander zu vergleichen.
Maximale Sendegeschwindigkeit | Diese Version lässt die Geschwindigkeitsbegrenzungen früherer Versionen weitgehend hinter sich. Die maximale Grenze wurde mit 4166 BpM (833 WpM) festgelegt. (Minimal 60 BpM/12 WpM). Dies sollte nun wirklich für jeden reichen. Bei ultrahohen Geschwindigkeiten kommt man dann auch zu dem Punkt, wo die Punktlänge die Schwingungslänge des Tones unterschreitet.
Optionen | allgemeine Parameter von RufzXP
Schrägstrichrufzeichen | Rufzeichen mit Schrägstrich
Toplist-Modus | Hauptmodus für den Einzelnutzer. Es werden 50 Rufzeichen mit einer variablen Anzahl von Schrägstrichrufzeichen gesendet. Top-Ergebnisse können an die wöchentlich erscheinende Internationale RufzXP-Toplist gesendet werden.
Toplist-Rufzeichen | Rufzeichen welches für das Erscheinen in der Internationalen RufzXP-Topliste genutzt werden soll. Dies sollte normalerweise gleich zum eigenen Rufzeichen sein. Ausnahme: Verwendung von Ex- oder Expeditionsrufzeichen während des Versuches. (sollte vermieden werden)
Trainer-Modus | Weitgehend konfigurierbarer Trainingsmodus. Empfohlen zum individuellen Verbessern der Hörfähigkeiten, besonders bei speziellen Zeichen.
Versuch | Ein Durchgang von RufzXP während dessen vom Computer eine bestimmte Anzahl von Rufzeichen oder Gruppen gegeben werden, die dann wieder aufgenommen werden müssen. Dabei erhält man für jedes gehörte Rufzeichen / Gruppe eine bestimmte Punktzahl. Die Summe der Punktzahlen im Versuch stellt das Ergebnis dar.


Tancredi

RufzXP: why "Tancredi"?

Sicherlich werden sich einige fragen, warum diese RufzXP-Version den Namen "Tancredi" trägt. Dafür gibt es einige Gründe ..
Tancredi ist der Held in Voltaires gleichnamiger Tragödie, hervorragend musikalisch interpretiert durch Gioachino Rossini in einem Meisterstück der Musikgeschichte, einer Verbindung zwischen der antiken barocken Welt und der neuen romantischen Oper, ..

Im September war einer der Autoren ( Alessandro Vitiello - IV3XYM ) beruflich in Oviedo unterwegs und spielte in seiner Freizeit mit Rufz32. Leider hatte er unter Windows 2000 Probleme das Programm über die DOS-Emulation laufen zu lassen. Dabei kam ihm die Idee eine Windows XP Version von RUFZ zu entwickeln. Zur gleichen Zeit sang seine Frau Rossinis "Tancredi" am Campoamor Theater, dem größten Theater Asturiens. Opernliebhaber kennen den Namen von Allesandros Frau: Mezzosopran Daniela Barcellona .

So schrieb er eine E-Mail an Mathias Kolpe (DL4MM) mit seiner Idee und dem Vorschlag, dieses Projekt gemeinsam zu realisieren, und einige Musterklassen für das zukünftige RufzXP. Der Teil der Soundgenerierung stammte aus einer Zusammenarbeit mit Stefano Bonetti, Komponist, Programmierer und Experte für elektronische Musik. Mathias war begeistert, und ein paar Wochen später ging das Projekt seinen Gang. Und während dieser Zeit weilte Alessandro in Rom wo auch sein Frau ein Engagement hatte - wieder mit Tancredi. :-D

Das Programm wurde also unter dem Einfluss Rossinis geboren, und wurde vereinbart, es nach Tancredi zu benennen. Natürlich auch als Dank an Daniela für ihre Hilfe und Geduld mit Alessandro während dieser Zeit.


Authors

Die Autoren

DL4MM

IV3XYM

Mathias Kolpe (DL4MM, ex DL3DZZ, ex Y33UL, ex Y66QL)

Gründer des RUFZ-Projektes und Programmierer aller früheren RUFZ-Versionen. Er hat für RufzXP alle Algorithmen für die Ergebnis- und Geschwindigkeitsberechnung geliefert und war am Programmlayout und der allgemeinen Gestaltung beteiligt. Er pflegt die deutsche Programmoberfläche sowie die RufzXP-Homepage und die International RufzXP-Toplist.

Geboren 1964, bekam er seine erste Amateurfunklizenz im Jahre 1981. Seit Beginn seines Amateurfunklebens ist er an DX und Contesten interessiert. Gegenwärtig sind 331 DXCC Entities bestätigt. 1990 errang er den Europasieg im SSB-Teil des WAE-DX-Contests. Weiterhin ist er regelmäßig Operator bei DF0HQ/DA0HQ. Zusätzlich war er sehr aktiv auf dem Gebiet der Schnelltelegrafie. Bis 1990 nahm er jährlich an den nationalen (ost-) deutschen Telegraphie-Meisterschaften teil. 1991 auch an den IARU High Speed Telegraphy Championships. Danach wurde er als DARC Verantwortlicher für die Schnelltelegrafie sowie als Mitglied der IARU High Speed Telegraphy Working Group berufen. Ende 2006 übergab er beide Ämter an seinen Nachfolger, und fungiert nunmehr als Internationaler Schiedsrichter.

Mathias, hat an der Technischen Universität Dresden Elektrotechnik studiert. Als Dipl.-Ing. für Elektrotechnik arbeitet er als Technischer Projektleiter in der Konstruktion von Hochspannungsschaltanlagen für eine größere französische Firma. Als Student kam er erstmals in Kontakt mit der Programmierung in Turbo Pascal. Ein erstes Projekt in seinem Berufsleben war die Programmierung eines Analysetools für digitale Schutzrelais basierend auf Turbo Pascal. Zu dieser Zeit kam auch die Idee RUFZ zu programmieren, natürlich in Turbo Pascal und zunächst nur für den eigenen Gebrauch. Sehr bald verbreitete sich die Software aber unter den CW-Freunden. Als Reaktion wurde die Software verbessert und eine Internationale Toplist im Internet gepflegt. Wenig später wurde RUFZ ein offizieller Bestandteil der HST-Telegraphie-Weltmeisterschaften.

In seinem Berufsleben kam Mathias in den letzten Jahren zunehmend in Kontakt mit Windows objektorientierter Programmierung und erstellte verschiedene Visual Basic Applikationen basierend aus dem Datenbanksystem MS ACCESS und SQL. Leider konnte durch einen Mangel an Zeit, verursacht durch Berufs- und Familienleben, sowie durch unzureichende Kenntnisse in der Windows Low-Level-Programmierung der RUFZ Umstieg von DOS zu Windows bislang nicht vollzogen werden. Aus diesem Grund war es ein Glücksumstand, einen hochtalentierten Programmierer (IV3XYM) als Ko-Autor zu finden, und zusammen die Kräfte für ein neues RufzXP zu bündeln.

Alessandro Vitiello (IV3XYM - IQRP#578)

Programmierer und Ko-Autor der letzten Version des RUFZ-Projektes. (RufzXP). Er plante und erstellte Klassen bzgl. der Morsecode- und Sound-Generierung, des Trainer-Modus und der Datenverwaltung. Er pflegt RufzXP und seine italienische Programmoberfläche.

Alessandro arbeitet als Pianist und Dirigent. Geboren in Triest, Italien, beendete er sein Studium bei Maestro Lorenzo Baldi und spezialisierte sich auf Lied- und Gesangstechnik bei Maestro Vagn Thordal bzw. das Dirigieren bei Maestro Gianluigi Gelmetti an der prestigeträchtigen "Accademia Chigian" in Siena. Er arbeite mit Dirigenten von internationalen Renommee wie G. Gelmetti und A: Zedda zusammen, und trat auf den Bühnen der meisten großen Festivale und Theater auf. (Rossini Opera Festival in Pesaro, Liceo of Barcelona, Genoa, San Sebastian, Lima, Tokyo, etc).

Er arbeitet regelmäßig mit weltberühmten Sängern zusammen. Dies als Piano-Begleitung oder Trainer, spezialisiert in Rossini und teilweise in Belcanto.

Mit 15 Jahren wendete er sich der Welt des Programmierens zu. Seine erste Software in Assembler schrieb er am Commodore C64. Später programmierte er in C,C++ (unter Linux in seinen ersten Versionen und Windows) und zuletzt in Visual Basic .Net und C#.Net.

Als Elektronik-Fan und SWL widmete er sich seit seiner Kindheit der Amateurfunkwelt mit dem Basteln von einfachen Sendern (meist CW). Im Jahre 2002 erhielt er seine Amateurfunk-Sendegenehmigung, und nun während seiner weltweiten Reisen, nutzt er seine Freizeit um QRP in CW auf den Bändern zu funken. Zuhause ist er auch auf den Satelliten-Frequenzen aktiv.

Im Jahre 2003 auf der Suche nach einer Software zur Verbesserung der CW-Fähigkeiten entdeckte er Rufz 3.2. Durch seine musikalische Erfahrung und die Trainingsalgoritmen von RUFZ konnten er sein Hörtempo von anfangs 80 BpM in zwei Monaten auf 245 BpM steigern. Durch die Kompatibilitätsproblem vom DOS-basierten RUFZ zum verwendeten Betriebssystem Windows 2000 entschloss er sich, zusammen mit Mathias Kolpe eine neue Rufz-Version, basierend auf dem MS .Net Framework zu entwickeln.

Danksagung

Für ihre wertvolle Hilfe an:

Stefano Bonetti: Musiker und Programmier, studierte Piano und Komposition, plante und realisierte Klassen bzgl. der Sound-Generierung und einige andere kleine Objekte.

Ulf Ehrlich (DL5AXX): Medizintechnik Service-Ingenieur, steuerte eine enorme Zahl von Rufzeichen aus den DA0HQ/DF0HQ-Logs als Rohbasis für die Rufzeichenbank bei.

Giovanna Ragnetti: Übersetzer und professionelle Dolmetscherin, hat den größten Teil der Dokumentation ins Englische übersetzt.

Marco Tuniz (IV3NCC - IQRP#509): Ehemaliger Berufsfunker, Funkamateur und Spezialist für Antennen und QRP-Geräte lieferte wertvolle Hinweise während der Softwareplanung.

Wolfram Heß, (DL1RXA, DK0DX): Autor, Film- und Radio-Sprecher und Redakteur. Er übersetzte einen Teil der Dokumentation ins Englische.

Dan Flanagan, (W3DF): hat für den "Ham code" - Trainermodus die Liste der verwendeten Abkürzungen bereitgestellt (http://www.qsl.net/w3df/cwabbrev.html).